Jump to content
cadman89

Funkcja Cut

Recommended Posts

Witam serdecznie

 

Zacząłem uczyć się 3dsmax'a, robię sobie tutki na yt, i mam banalny problem. Otóż tworzę sobie model shotgun'a, wrzuciłem fotkę, wykonałem obramowanie funkcją Create, powstał chyba plane, i teraz chciałbym go za pomocą funkcji Cut, uciąć wzdłuż, wstawić tym samym kilka vetex'ów wewnątrz, żeby to wyglądało miej więcej tak jak tutaj (screen z tutorial'u)

attachment.php?attachmentid=105136&stc=1&d=1531230079

 

 

 

Natomiast u mnie wygląda to tak :

screen1

attachment.php?attachmentid=105137&stc=1&d=1531230690

 

 

 

screen 2

attachment.php?attachmentid=105138&stc=1&d=1531230723

 

 

 

 

screen 3

attachment.php?attachmentid=105139&stc=1&d=1531230817

 

 

Zdaję sobie sprawę, że wiecie jak można to zrobić na 10 innych sposobów, ale wcześniej używałem tej funkcji i takiego problemy nie było...

 

Gdyby Ktoś znalazł chwilę, to proszę o jakąś poradę.

Share this post


Link to post
Share on other sites

Próbowałem właśnie z ciekawości zrobić identycznie jak masz na screenach i nie było takiego problemu. Sprawdź może czy nie masz w tym miejscu jakichś podwójnych linii, albo czy jakieś vertexy nie są jeden na drugim. Możesz też spróbować zaznaczyć wszystkie i dać 'weld' z małą wartością, może jakiś się tam zawieruszył.

Share this post


Link to post
Share on other sites

Zrobiłem jeszcze raz nowe obramowanie przy pomocy Create, powstaje wtedy nie jak wcześniej pisałem plane tylko polygon, ale funkcja Cut działa nadal tylko od vertex'a do vertex'a. Więc nie ma mowy o nałożonych liniach, edge'ach. Użyłem funkcji Weld z małą wartością, tak jak pisałeś ale to nic nie zmieniło.

Share this post


Link to post
Share on other sites

Właśnie też tak myślałem, próbowałem nawet na border ale to nic nie zmienia. Ten Anglik, który prowadzi tutorial, na którym ja też bazuję ma wybrane vertex'y podczas używania Cut. Tu podrzucam linka, moment tej operacji to 04:42 minuta. Nie wiem może ma coś ustawione, może coś przeoczyłem.

Film powinien się odpalić w czasie używania funkcji Cut.

 

Share this post


Link to post
Share on other sites

Zrobiłem to inaczej, stworzyłem oddzielnie same vertex'y, a potem funkcją cut po nich ciąłem, więc jakoś się udało. Ale coś jest nie tak, bo podczas używania funkcji cut, ona cały czas szuka tylko prostopadłych połączeń z edge'ami... Nie wiem ale wydaje mi się, że jak w AutoCadzie, chyba są tu jakieś ustawienia przyciągania czy kierowania np prowadzonej linii.

 

Mimo wszystko Wielkie dzięki za pomoc.

Share this post


Link to post
Share on other sites

Zacząłem prace na viewport'cie z ustawieniem Left, tak jak gość na tutorial'u, odwróciłem na Right i działa :) Trochę to dziwne, bo już wcześnie robiłem ten sam model na lewej stronie i nie było problemu, ale pomogło. Taka błahostka.

 

Bardzo dziękuję "polka dot" :)) Ponad 6 tys. postów to już doświadczenie.

Share this post


Link to post
Share on other sites

I znowu nie działa... obojętnie z której strony próbuję użyć funkcji Cut, ustawiłem nawet Top i Front, nie wiem o co kaman.

Share this post


Link to post
Share on other sites

Możesz jeszcze odwrócić poligon funkcją filp i spróbować.

Nie zrozum mnie źle, ale Cut tak po prostu ma. To stare narzędzie które nie lubi pracy w widokach ortogonalnych, ma automatyczny snap którego nie da się wyłączyć, potrafi nawet przy prostych operacjach zawiesić maxa.

 

A Twój problem to ogólnie znany problem.

google wypluwa kilka wątków z rożnych for bez rozwiązania, najstarsze z 2006 roku

https://www.google.com/search?q=3ds%20max%20cut%20snaps%20to

Share this post


Link to post
Share on other sites

@stormwind nie da się ciąć backface.

Nigdy się nie spotkałem z tym problemem, jaka to ver. 3ds Max?

Share this post


Link to post
Share on other sites

Flip pomogło, chaotyczne narzędzie Cut zadziałało jak trzeba. Może właśnie czasami trzeba tak potraktować tą funkcją jakiś polygon, żeby usprawnić cięcie. Wielkie dzięki :) Rzeczywiście mało dokładnie sprawdziłem temat na googl'ach.

 

Wersja 3dsmax 2013

Share this post


Link to post
Share on other sites

Znaczy to, że chciałeś ciąć backface, sprawdź którą stronę poly tniesz, zanim zaczniesz cięcie :)

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy