Jump to content

Szybkie odpowiedzi na proste pytania. Blender Q&A


n-pigeon
 Share

Recommended Posts

teraz śmieszna sprawa i morał taki, że użycie pamięci trzeba wróżyć z fusów w cycles, albo z baranich wnętrzności, bo inaczej to nie wiem jak.

 

Pamięć użyta wyświetlana przy renderowaniu przez blendera, to se można wsadzić, to już wiem, ale sądziłem, że takie programy jak GPU-Z pokazują pamięć użytą dobrze. No więc w domu na karcie z 4giga zajęła mi scena 99% pamięci, zoptymalizowałem i dostałem od 3339 do 3450 zależy, czy używam tych instancji, czy nie (paradoksalnie więcej jest z instancjami, no ale cóż) Całą niedzielę siedziałem jak świstak i optymalizowałem, zmniejszałem tekstury, robiłem instancje, bo jeszcze kilka tekstur mam dodać, a chciałem renderować na karcie.

 

Ale z głupoty przyniosłem plik do pracy i puściłem go na karcie z 2 giga vramu - liczyłem na czarny ekran, a tu renderuje się i zajęło 1.9 Giga z jakimś groszem vramu i pisze mi, że to 99%. i się wyrenderowało!!!

 

 

To kurde jak to jest, ile tego ramu potrzeba, bo wygląda, że bierze ile znajdzie, a to minimum, poniżej którego kernel wywali błąd jest nie do przewidzenia.

Link to comment
Share on other sites

@ikkiz wrzuć blenda z tym oknem; zazwyczaj modyfikatory powodują, że instancje przestają być instancjami, próbowałeś zmienić nazwę obiektu/mesh data? Renderujesz przez F12 czy dynamicznie z viewportu?

Link to comment
Share on other sites

nie ma modyfikatorów i pewnie oszczędność pamięci jest na instancjach, tylko z czym innym jest problem, że blender zgarnia prawie całą dostępną pamięć, bo to co na mojej karcie zajmowało prawie całość z 4 giga, wyrenderowało się na 2 gigowej karcie bez problemu. potem dodałem kilka tekstur i znów się zmieściło w tych 2 giga zajmują prawie całość.

 

Nawet nie próbowałem, jak będzie to wyglądać z samym oknem, sprawdzę i jak by się nie zgadzało z przewidywaniami, to podeślę.

ale problem pojawia się przy całej dowalonej scenie, ktorej na razie nie chce wysłać, bo tam nie wszystkie moje modele.

Link to comment
Share on other sites

@ikkiz a podglądałeś dokładnie zasoby systemu, tzn. ile de facto masz wolnej pamięci vram? Może to kwestia OS, systemu graficznego itd. i zarządzania pamięcią bardziej niż*kwestia samego blendera; jaka to karta dokładnie?

Link to comment
Share on other sites

Help!

Panowie, pewnie banalne ale...

Mam problem przy renderowaniu plane'a z alpha mapą liścia.

Blender 2.74, Cycles.

Renderuje mi owszem widok liścia, ale cień też rzuca plane a tego nie chcę.

Gdzieś tam się doszukałem, że Blender ma problemy z texturami z alphą.

Więc zrobiłem dwa obrazki, jeden czarno biały obraz jpg jako alpha a drugi zwykły kolor też jpg, podłączyłem i cały czas to samo...

Co robię nie tak?

Będę wdzięczny

Link to comment
Share on other sites

Zapisz alfę jako PNG albo inny bezstratny format i ustaw tą image nodę jako Non-Color data (pierwsza opcja w nodzie). Obrazki które mają ustawione Color Data są poddawane konwersji przestrzeni barw czyli to co wyglądało na czarne/białe na twoim obrazku nie będzie czytane jako pełna czerń/biel. Szczególnie w przypadku JPG który jest stratnym formatem i nie zapisuj dokładnie kolorów. Nie korzystaj z tego formatu robiąc materiały, on powinien służyć jedynie do zapisywania obrazków do sieci.

Link to comment
Share on other sites

Tak robiłem na początku, przestawiłem ponownie - nadal to samo.

Czy oświetlenie sceny mapą hdri może generować takie problemy?

Mam obecnie ustawione dla world environment texture i plane z emission.

Przestawiłem przy tym nody delikatnie.

 

- - - Połączono posty - - -

 

Po wyłączeniu hdri w background, wygląda dobrze wg. Twoich ustawień.

Tylko, że ja chciałbym żeby to hdri świeciło...

Link to comment
Share on other sites

@illusion, jest coś takiego, że jak komponujesz noda a wcześniej masz zapuszczony render we viewporcie, to blender nie odświeży tego node'a i dlatego renderuje Ci cień*plane'a. Jak odświeżysz renderowanie albo puścisz render przez F12 to nie ma opcji, żeby cienia nie liczył z alphy i wystarczy do tego zwykły obrazek z kanałem alpha np. "png" bez dodatkowych czarno-białych plików.

Edited by alex3d
Link to comment
Share on other sites

Noo fajnie, tylko że problem znika gdy wywalę ze sceny hdri i wraca, gdy wrzucam ją ponownie... przy zwykłym oświetleniu w cyclesie renderuje się ok, gdy dodam jeszcze hdri w world/background to wtedy pojawia się ten cień.

Próbowałem już budować nowe sceny i tak samo.

Dzięki za zainteresowanie i pomoc.

Link to comment
Share on other sites

a tak wracając do problemu z liściem, używasz AO ?

transparent shadow zaznaczone?

 

a może za mało bołnsów na transparentne, tzn jak używasz hdri do oświetlania to ente promienie nie używają transparenta tylko diffuse.... a przy prostym oświetleniu to nie wychodzi że za mało odbić promienia w ustawieniach...

Link to comment
Share on other sites

Witam

Problem z prostym obiektem. Wydaje mi się że wcześniej tego nie było. W załączniku plik i już tłumaczę o co chodzi. Chciałem zrobić sobie texturkę tileable kamiennej podłogi i jak zwykle na początku ustawiłem sobie w edit mode cuba tak, żeby boczne płaszczyzny pokrywały się z osiami x,y,z (pomocne przy wszelkiego rodzaju skalowania,exporcie itp) następnie przeskalowałem. Po przesunięciu w konkretne miejsce zrobiłem x2 subdivide, subsurf x2 ->accept oraz multiresolution x1. Przed przejściem do sculpt mode jeszcze tylko mode ctrl+A ->scale. Problem pojawia się przy rzeźbieniu lewej (patrząc z góry ) płaszczyzny (plik test_sculpt.blend_1.zip) pojawia się mocne zniekształcenie. Problem znika dopiero gdy wykonam ctrl+A ->Location tylko że wtedy mój 3d manipulator wraca do środka osi i utrudni mi późniejsze manipulacje obiektem - przesuwanie , skalowanie, obracanie.

Wcześniej tzn jakieś 2 miesiące temu robiłem ściany i tego problemu raczej nie miałem bo bym zwrócił na niego uwagę. Coś namieszali w buildach ? Korzystam z daily build

test_sculpt.blend_1.zip

Link to comment
Share on other sites

Szybkie pytanie jak ktos znajdzie czas - prosty material z color rampa taki:

24MaybK.jpg

Wszystko ok, ale jak zrobic taki sam material do obiektu powyginanego (modyfikator curve), tak zeby ta zolta linia wciaz przechodzila przez srodek a nie zanikala gdzies na brzegach (w obu przypadkach nie ma zadnych UV rozlozonych):

 

SKdwSJs.jpg

Link to comment
Share on other sites

Można rozłożyć UVkę i wybejkować Diffuse Color na ustawieniu gdzie linia układa się tak jak chcesz. Potem przypniesz uzyskaną teksturę zamiast colorrampa i już.

 

Albo jeszcze prościej... i bez uv mapki. Zaznaczasz w edit mode ścianki, które mają być żółte i przypisujesz im żółty materiał. Wymaga to odpowiedniego podziału geometrii na wieczku i denku, ale w tym przypadku to sekunda.

Link to comment
Share on other sites

Dzieki Vaticinator, ale ta zolta linia to jedynie przyklad majacy zilustrowac dokladniej problem. Tam moze byc jakikolwiek color ramp - jedynie nie kumam dlaczego przy powyginanym obiekcie jakies cuda robi z ta rampa...

Link to comment
Share on other sites

Generated coordinate. On uwzględnia deformacje mesha (lub nie uwzględnia, zależy jak to rozumieć. ;) ).

 

GVoOJuK.png

 

(Zamiast separacji kanałów możesz tam Mapping node wstawić żeby dodatkowo tym obracać jeśli potrzebujesz.)

Link to comment
Share on other sites

Witam wszystkich,

czy zmagał się ktoś z problemem z "child of" constraint? chodzi o to, że kiedy poruszam rigiem bez dodawania klatek, kość z child of podąża właściwie, ale kiedy dodam klatki, modyfikator głupieje kompletnie. Taka prosta rzecz, a jednak Blender musi pokazać, że ma własne zdanie.

Link to comment
Share on other sites

Czy ma ktoś z Was pomysł na to dlaczego nie mogę "już" odpalić blendera wersji 2.63, 2.66, 2.69, 2.70 ? mam je na kompie i na nich swego czasu pracowałem, nic nie robiłem z kompem itp. Wchodziła nowa wersja to ściągałem daily build'a i robiłem na nowszej. A ostatnio chciałem coś sprawdzić i zonk. 2.61, 2.71, 2.72, 2.73, 2.74 normalnie działają.

Link to comment
Share on other sites

Nie możesz rozdzielać geometrii split edgem i wtedy nakładać subdiva. Powinieneś wymodelować loopy na obiekcie w taki sposób żeby podczas subsurfa pozostała tam ostra krawędź. Dodaj w tym miejscu dodatkowe support loopy, możesz bevelem na przykład (operatorem modelowania, nie modyfikatorem).

 

http://cgi.tutsplus.com/tutorials/quick-tip-understanding-support-edge-placement--cg-7491

Link to comment
Share on other sites

Chciałbym zrobić symulację czegoś wpadającego do wody przy założeniu, że ciecz jest w misce lub innym naczyniu.

Jak to zrobić aby ciecz w misce była od razu "spokojna" Kombinowałem, próbowałem kopiować ściany naczynia i je odwracać. Za każdym razem przy rozpoczęciu symulacji płyn musi się najpierw w naczyniu ułożyć.

Jak to zrobić żeby ciecz w naczyniu była od razu nieruchoma?

Link to comment
Share on other sites

Nie da się w jednej scenie (mowa o blenderowej scenie, nie pliku .blend) mieć innych ustawień renderu. Możesz skopiować tą scenę (tak żeby korzystała z tych samych obiektów) i w niej zmienić ustawienia renderu. Nawet silnik renderowania możesz zmienić na inny. Jeśli będziesz chciał łączyć potem te rendery w comositorze to możesz stworzyć nową scenę.

 

http://urchn.org/post/combining-blender-internal-and-cycles-in-one-render

Link to comment
Share on other sites

wybaczcie może głupie pytanie ale trochę wypadłem z obiegu a nie mogę sobie przypomnieć czy jest sposób by przeprowadzić konwersje z powiedzmy quad/tris na hexagonal ?, coś mi świta po głowie ale nie mogę sobie tego przypomnieć

 

Edit: oczywiście w trakcie pisania jak zawsze mi się coś przypomina, jakby co to napiszę jak to poszło

Edited by mandragora
Link to comment
Share on other sites

Mam problem z materiału przechowującego informację o przezroczystości tak aby był poprawnie wyświetlany na p3d.in

W Blenderze poprawnie wyświetla transparentnoś czytaną z czarno-białego jpg ale na p3d widzę tylko czarne plane. Podpowiecie jak poprawnie skonfigurować materiał?

Link to comment
Share on other sites

no dobra, to jest jakieś wyjście, ale czy da rade realtime bez zabawy w compositor?

chodzi mi o taki pantent jak był w internalu

2jdm3y0.png

 

edit, jeszcze jedno pytanie, w jaki sposób w cycles wypalić (to co widze w podglądzie 3d)/(to co wychodzi z render image) do TEXTURY, nie zrobili takiej opcji?

Edited by rice
Link to comment
Share on other sites

Jak zrobić materiał drewna?

Ten, o który mi chodzi chyba nie jest aż tak prosty.

Mam tu na myśli coś w rodzaju deski prosto spod piły/pnia ściętego drzewa.

 

Taka deska prócz tekstury deski pokryta jest jakby meszkiem z kurzu i opiłków drewna.

Jak zrobić coś takiego?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy