Jump to content
Martin Day

Puste buckety

Recommended Posts

Witam,

 

Zawsze gdy rendeuje cos na czarnym tle VRay pomija te buckety, ktore "maja malo do wyrendeowania". Nie jest w stanie dojsc czego jest to przyczyna. Nie znalazlem zadnych zaleznosci. Problem ten mam od dawna wiec nie jest to tez kwstia konkretnej wersji VRay'a. Puste buckety pojawiaja sie zupelnie przypadkowo, rowniez w kanale alpha. Renderujac te samea klatke dziury pojawiaja sie (jesli wogole) w roznych miejscach.

 

Czy ktos ma pojecie jak sie tego pozbyc?

 

emptybuckets.jpg

 

Dziekuje za pomoc

Marcin

Share this post


Link to post
Share on other sites

Nie masz przypadkiem włączonego distributed rendering?

Przy innych scenach też występuje problem?

Share this post


Link to post
Share on other sites
Nie masz przypadkiem włączonego distributed rendering?

 

No wlasnie zapomialem dodac. To NIE jest distributed rendeing.

Dzieje sie tak renderujac lokalnie i na farmie.

Share this post


Link to post
Share on other sites

Może Optimized atmospheric evaluation.

Problem pojawia się w innych, prostych scenach?

Share this post


Link to post
Share on other sites

To nie jest kwetia czy renderuje atmospherics czy nie. Tak, problem sie powtarza i powtarza wszedzie w podobnych sytuacjach.

 

Zalaczam render z show samples

 

showsamples.jpg

Share this post


Link to post
Share on other sites

hmmm, a sprawdzałeś na innym kompie?

Czy bucket, który wychodzi pusty jest liczony długo, czy pojawia się i momentalnie leci na następny obszar?

Share this post


Link to post
Share on other sites
hmmm, a sprawdzałeś na innym kompie?

Czy bucket, który wychodzi pusty jest liczony długo, czy pojawia się i momentalnie leci na następny obszar?

 

Nie jest to zalezne od kompa. Na kazdym mam to samo. Puste buckety sa "rendeowane" w ulamek sekundy. Poprostu VRray nie daje tam zadnych sampli.

Doszedlem (w sumie to oczywiste), ze pomaga zwiekszenie Min. Subdivision. albo renderowanie na Fixed. To nie stety spowalnia miejsca, ktore faktycznie mogly by sie obyc z 1 subd.

Share this post


Link to post
Share on other sites

Wrzuć scenę gdzie występuje problem i przyjrzę się temu. Ogólnie dziwna sprawa.

Share this post


Link to post
Share on other sites

Murphy sie tu wtracil bo probuje wlasnie odtworzyc podobna prosta scene i mi tego nie robi :/ tzn dziur nie renderuje. Oryginalnej sceny niestety nie moge Ci wyslac.

Share this post


Link to post
Share on other sites

Bardzo często jest tak, że jakieś dodatki do programu jak na przykład pluginy maja problem przy liczeniu bucketami w kolejności innej niż naturalna czyli tak jak liczy scanline - z góry na dół. To samo przy używaniu Bitmap Pagera, albo spada wydajność odczytu fragmentów z dysku, albo w ogóle nie czyta map. Być może problemem tkwi w którymś z elementów sceny.

Share this post


Link to post
Share on other sites
Bardzo często jest tak, że jakieś dodatki do programu jak na przykład pluginy maja problem przy liczeniu bucketami w kolejności innej niż naturalna czyli tak jak liczy scanline - z góry na dół. To samo przy używaniu Bitmap Pagera, albo spada wydajność odczytu fragmentów z dysku, albo w ogóle nie czyta map. Być może problemem tkwi w którymś z elementów sceny.

 

Probowalem zmieniac wielkosc bucketow i region sequence... to samo :(

ale... wpadlem na pomysl. Przynajmiej w konkretnym przypadku sie sprawdza.

Bucket na szerokosc rendeingu i wysokosc 5-10 pixeli.

Share this post


Link to post
Share on other sites

A nie możesz podesłać odtworzonego fragmentu sceny typu boxy i występujący problem? Jeżeli próbujesz odtworzyć problem i się nie pojawia to wstaw obiekty z błędnego pliku do nowej sceny.

Może problem leży w tym fogu. Napisz jak go robiłeś. Jakieś efekty w scenie, nietypowe światła, pluginy zewnętrzne. Czy problem występuje jak masz w tle czarny obiekt a nie enviro?

Druga rzecz może masz wrzucony skrypt który zmienia ci ilość rdzeni w vrayu i tu coś się krzaczy.

Tak to tylko strzelać można.

Edited by PICsell

Share this post


Link to post
Share on other sites
A nie możesz podesłać odtworzonego fragmentu sceny typu boxy i występujący problem? Jeżeli próbujesz odtworzyć problem i się nie pojawia to wstaw obiekty z błędnego pliku do nowej sceny.

Może problem leży w tym fogu. Napisz jak go robiłeś.

Druga rzecz może masz wrzucony skrypt który zmienia ci ilość rdzeni w vrayu i tu coś się krzaczy.

Tak to tylko strzelać można.

 

To nie jest kwestia foga bo mialem to wczesniej w roznycj innych sytuacjach. Skryptu tez nie mam, przynajmiej nic o tym nie wiem :)

Jesli chodzi o scene to wlasnie tak zrobilem. Wywalilem wszystko podmienilem niektore rzeczy na prymitywy i zniknelo :) Moze faktycznie jakis smiec jest w scenie. Pokopie glebiej.

 

Dzieki

Share this post


Link to post
Share on other sites

Tak z ciekawości, w pierwszym poście napisałeś że problem występuje jak renderujesz na czarnym tle. Zmiana koloru zmiania sytuacje? Używasz frame bufera? Mi to wygląda na jaiś syf w setupie vrayowskim.

Edited by PICsell

Share this post


Link to post
Share on other sites
Tak z ciekawości, w pierwszym poście napisałeś że problem występuje jak renderujesz na czarnym tle. Zmiana koloru zmiania sytuacje? Używasz frame bufera?

 

 

Na innych kolorach jest to samo... ogolnie chodzi o jednolite "puste" tlo.

Nie ma znaczenia czy w maxowym framebufferze czy vray'owym

Share this post


Link to post
Share on other sites

A pomaga przestawienie na 16 bitowego maxowego frame buffera? Bo mi czasami max troszkę wariował jak miał obsłużyć 32 bity.

Share this post


Link to post
Share on other sites
A pomaga przestawienie na 16 bitowego maxowego frame buffera? Bo mi czasami max troszkę wariował jak miał obsłużyć 32 bity.

 

sprawdze...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy