Jump to content

Lagujący łańcuch IK (a właściwie kości)


Recommended Posts

Witam, dzień bez problemów z animacją to dzień stracony... Co tym razem?

 

Mam w końcu gotowego riga (poprawki wyjdą podczas animacji), gotowy system kości, gotowe łańcuchy IK, wszystkie kontrolki itp.

Pomyślałem, że teraz wystarczy się już tylko zamknąć w pokoju, zasłonić okna, i animować tylko z przerwami na jedzenie i podstawowe potrzeby fizjologiczne. Przygotowałem wszystko jak należy - zapas picia, jedzenia, warunki idealne.

 

Zacząłem animować.

 

Nosz ku....źwa. Na dzień dobry jakbym dostał naleśnikiem w twarz.

 

Każdy z palców ma swój łańcuch IK, który jest podlinkowany pod kontroler (na filmiku poniżej różowa mała bryła). Podczas przesuwania kontrolera ruchem jednostajnym prostoliniowym, tak samo przesuwa się koniec łańcucha IK. Teoretycznie tak samo gładko powinien przesuwać się koniuszek palca. Ale nie. Max stwierdził, że lepiej dla animacji będzie kiedy głównej postaci zafundujemy Parkinsona:

 

 

Kontroler ma pivota dokładnie tam gdzie koniec łańcucha, jedyne co laguje to kości - łańcuch chodzi gładko...

 

Co się dzieje? :D

Edited by Szczepenson
Link to post
Share on other sites

Postać ma wg. skali 400cm wysokości, musiałem ją powiększyć z ok. 190cm, ponieważ ktoś zrobił scenę w innej skali - czy to mogło być przyczyną?

 

Dodam, że usunięcie obecnego łańcucha i stworzenie nowego w niczym nie pomaga :

Edited by Szczepenson
Link to post
Share on other sites

Ogolnie to nigdy nie doskalowujesz swiata do rigga tylko odwrotnie. Takie kwiatki na IK zazwyczaj wynikaja ze złej skali, ale glownie zbyt malej a nie ze zbyt duzej. Sprawdz czy nie masz ustawiony ze jeden unit = np. 0,001 cm lub cos takiego. Inna rzeczą moze byc przestawiony iterations na IK goalu w zakladcie potion, defaultowo powinno byc ustawione 40.

 

druga zasada to taka, ze nigdy nie skaluj rigga, chyba ze parametrycznie bo to powoduje masę problemów i nie przewidzianych roznych dziwactw. Sprawdz jak sie te palce zachowywaly na riggu ktory mial normalna skale 190.

Link to post
Share on other sites

O, coś się zadziało!

 

Zachęciłeś mnie do eksperymentów, więc metodą prób i błędów pobawiłem się wartością iterations zwiększając ją jakieś 2 razy, i dodatkowo grzebiąc w parametrach po całości zmieniłem wartości pod "Tresholds" na 0. Nie wiem dlaczego, ale wydaje się działać, dzięki wielkie!

 

A na skali 190 także występował ten sam problem, więc naprawdę nie mam pojęcia co mogło być przyczyną. O.o

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy