Jump to content
Sign in to follow this  
Mirrage

Problem z uruchomieniem Houdiniego na Linuxie

Recommended Posts

Zainstalowałem właśnie Houdiniego na nowo powstałym CentOS lecz pojawił sie problem z jego uruchomieniem gdyż próbowałem odpalić go klikając na ikonkę ale również z konsoli, która wyrzuciła mi komunikat, iż w tmp znajduje się txt z logiem odnośnie crashowania się programu i wygląda on tak:

 

Crash report from aoe; Houdini FX Version 14.0.201.13 [linux-x86_64-gcc4.8]

Uptime 0 seconds

Sun Sep 27 17:42:19 2015

Caught signal 11

 

Traceback from 6071 ThreadId=0x7fcea137b980

AP_Interface::coreDumpChaser(UTsignalHandlerArg)

AP_Interface::si_CrashHandler::chaser(UTsignalHandlerArg)

signalCallback(UTsignalHandlerArg)

UT_Signal::UT_ComboSignalHandler::operator()(int, siginfo*, void*) const

UT_Signal::processSignal(int, siginfo*, void*)

_L_unlock_13

QReadWriteLock::lockForWrite()

QGLWidget::deleteTexture(unsigned int)

QGLContext::~QGLContext()

QGLContext::~QGLContext()

QGLWidget::~QGLWidget()

re_QGLWidget::~re_QGLWidget()

QObjectPrivate::deleteChildren()

QWidget::~QWidget()

QWidget::~QWidget()

QObjectPrivate::deleteChildren()

QWidget::~QWidget()

re_QWindowWidget::~re_QWindowWidget()

RE_QtWindow::~RE_QtWindow()

RE_QtWindow::~RE_QtWindow()

UI_Window::~UI_Window()

QT_Window::~QT_Window()

FUSE_AnonymousStats::~FUSE_AnonymousStats()

FUSE_AnonymousStats::~FUSE_AnonymousStats()

FUSE_App::~FUSE_App()

FUSE_App::~FUSE_App()

FUSE_HoudiniBinariesApp::~FUSE_HoudiniBinariesApp()

__run_exit_handlers

__GI_exit

UT_Exit::doExit(int, bool)

RE_OGLRender::initGLState()

RE_OGLRender::makeCurrent(bool)

RE_OGLRender::lockContextForRender()

RE_QtWindow::openWindow(int, int)

QT_Window::doOpen()

UI_Window::handleEvent(UI_Event*)

UI_Queue::processNextEvent()

UI_Queue::drain()

UI_Queue::drainEvents(bool, bool)

OPUI_MainApp::loadFilesAfterUiOpen(UI_Event*)

UI_Queue::processNextEvent()

UI_Queue::drain()

UI_Queue::eventLoop()

main

__libc_start_main

_start

 

 

Ma ktoś jakiś pomysł ponieważ nie mogę sie doszukać błędu. Taką samą wersję edukacyjną mam na moim Windowsie i wszystko jest ok.

Share this post


Link to post
Share on other sites

Na dobry początek proponował bym spróbować z bardziej aktualną instalką Houdiniego. :)

 

Proponował bym próbować z wersjami 14.0.4xx

Edited by ZirakKhazad

Share this post


Link to post
Share on other sites

To jest właśnie najnowsza dostępna na stronie wersja :( Gdzieś czytałem, że jest to problem z OpenGL.. Zapomniałem wspomnieć, że instalowałem na VMware 10

Share this post


Link to post
Share on other sites

Nie widze zadnych problemow na centosie. upewnij sie, ze to najnowsza, STABILNA wersja oraz, ze masz najnowsze sterowniki Nvidii.

Jest jakis sens instalowania tego przez VMware??

Share this post


Link to post
Share on other sites

Czy problem jeszcze istnieje?

 

Wersja jest jak w komunikacie o błędzie czy już 14.0.444?

 

Jaką wersje sterowników do karty graficznej masz zainstalowaną?

Edited by ZirakKhazad

Share this post


Link to post
Share on other sites

Nie widzi urządzenia OpenGL, VMWare nie wspiera zdaje się wirtualizacji OpenGL na Linuksie (tylko Windows?).

Share this post


Link to post
Share on other sites
Nie widzi urządzenia OpenGL, VMWare nie wspiera zdaje się wirtualizacji OpenGL na Linuksie (tylko Windows?).

 

Dokładnie tak jak napisał SYmek i udało mi się to również wyczytać w internecie. Zrezygnowałem więc z VM i zainstalowałem na twardzielu. Mam zainstalowane najnowsze sterowniki do mojej karty graficznej lecz pojawił się popularny problem z rozdzielczością. Na jednym z monitorów jest ok czyli 1920x1080 a na drugim max jaki mogłem dać to 640x480 gdzie po dodaniu kilku wpisów w xorg.conf udało mi się zmienić ten limit do 1024x768 lecz ciągle nie mam pojęcia jak uzyskać taką rozdzielczość jak na tym, który ma 1920x1080. Poniżej wrzucę xcorg i zaraz zabiorę się za instalację Houdiniego i mam nadzieję, że teraz nie będzie problemu. Obym się odnalazł w tym środowisku :) Nie ma to jak Program Files na Win gdzie wszystkie programy się instalują :D

# nvidia-xconfig: X configuration file generated by nvidia-xconfig

# nvidia-xconfig: version 340.93 ([email protected]) Wed Aug 19 17:11:04 PDT 2015

 

Section "ServerLayout"

Identifier "Layout0"

Screen 0 "Screen0"

InputDevice "Keyboard0" "CoreKeyboard"

InputDevice "Mouse0" "CorePointer"

EndSection

 

Section "Files"

FontPath "/usr/share/fonts/default/Type1"

EndSection

 

Section "InputDevice"

# generated from default

Identifier "Mouse0"

Driver "mouse"

Option "Protocol" "auto"

Option "Device" "/dev/input/mice"

Option "Emulate3Buttons" "no"

Option "ZAxisMapping" "4 5"

EndSection

 

Section "InputDevice"

# generated from default

Identifier "Keyboard0"

Driver "kbd"

EndSection

 

Section "Monitor"

Identifier "Monitor0"

Option "Enable" "True"

VendorName "Unknown"

ModelName "Unknown"

#HorizSync 28.0 - 33.0

#VertRefresh 43.0 - 72.0

Option "DPMS"

EndSection

 

Section "Device"

Identifier "Device0"

Driver "nvidia"

VendorName "NVIDIA Corporation"

Option "NoLogo" "1"

Option "RenderAccel" "1"

Option "RegistryDwords" "PerfLevelSrc=0x3333"

EndSection

 

Section "Screen"

Identifier "Screen0"

Device "Device0"

Monitor "Monitor0"

DefaultDepth 24

Subsection "Display"

Depth 24

Modes "1920x1080_75.00"

EndSubsection

EndSection

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy