Jump to content

export z Autocada do 3dmaxa okragłe krawędzie


nitrograd
 Share

Recommended Posts

Witam!

Przenosząc okrągłe obiekty z Cada do Maxa napotykam na problem.Mianowicie w maxie okrągłe obiekty okazują się być "kanciaste".

Próbowałem już exportować przez 3d Viza, ale efekt jest ten sam.

czy ktoś mial z tym już do czynienia?Rozwiązanie ejst w cadzie czy w 3d studio?

 

Z gory dziekuję!

Link to comment
Share on other sites

autocad to dziwny program :D wyexportuje to co widać - czyli jak jesteś daleko od meshy to wyexportuje takie kańciaste.

Zbliż się do krawędzi okrągłego obiektu (ZOOM) . napisz z klawiatury REGEN (skrót chyba re) aby przez odświeżenie widoku CAD wygładził krawędź. następnie napisz EXPORT, i jak Cie spyta co exportować to napisz z klawiatury ALL.

odznacz autosmooth , bo działa jakoś koślawo.

zaimportuj do maxa i sprawdź czy nie masz zbyt dużo trójkątów.

Jeżeli za dużo to nie zbliżaj się tak mocno do okrągłej krawędzi mesha to CAD wyliczy mniej punktów tworzących.

Jeżeli chcesz exportnąć wyokrąglone polilinie to raczej się nie uda. mi sie niegdy nie udawało :D

Walcz jak lew!

Link to comment
Share on other sites

Jak domniemam chodzi Ci o jakies bardziej miekkie formy.

W autocadzie przed exportem wpisz magiczne polecenie surftab1.

Po czym wpisujesz cyfre (domyslnie jest ustawiona 6) np. 50.

Zobaczysz wtedy co sie stanie z twoim modelem (siatka na obiektach powinna sie zwiekszyc, ale tylko w jednym kierunku).

Po tej czynnosci wpisujesz surftab2 i jak poprzednio zwiekszasz liczbe.

Da sie to rozwiazac jeszcze innym sposobem, ale musial bym zobaczyc model. A jak nie zobaczyc to chociaz go opisz (chodzi o to czy jest to model organiczy)

Link to comment
Share on other sites

Peter ty moze piszesz o opcjach wyswietlania obiektu. Żeczywiscie one nic nie zmieniaja w modelu (jezeli model byl wczesniej wykonany).

Mozna to obejsc w prosty sposob. Otwierasz nowy plik i w nim ustawiasz lepsze parametry wyswietlania. Po tej operacji wklejasz model do wlasnie tak przygotowanego pliku.

Link to comment
Share on other sites

Troche popie....lem.

Masz racje Peter z tym surftabem.

Ale jak pisalem wczesniej mozna to obejsc kopiujac model do nowego pliku w ktorym wczesniej zwiekszamy parametry wyswietlania (Tools>Options>Display>Display resolution).

Po tym zabiegu w maxie juz powinno byc ok (oczywiscie trzeba sie troszke pobawic bo siatka moze sie okazac za gesta)

Link to comment
Share on other sites

parametry o ktorych mówisz są odpowiedzialne tylko i wyłącznie za wyswietlanie (facetres , isolines) i nie mają nic wspólnego z importem modelu do maxa. poza tym nie trzeba tworzyc nowego pliku, wystarczy regen all.

 

znaczenie ma

ustawic mniejszy "surface deviation for 3d solids" czym mniejszy parametr tym bardziej zaokraglone a to sie ustawia juz przy imporcie w maxie
Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy