Jump to content

Render Elelements - Shadow pass problem


espo
 Share

Recommended Posts

Witam, mam pewien problem. Renderuje dwa passy Diffuse (z Lighting) i Shadow, gdy ich polaczam powstaja pixels przy podstawach objektoow, w tych miejscach, gdzie zlaczja sie dwa passy. W czym to moze byc problem? Jak tego uniknac?

W danym wypadku uzywam scanline i ray traced shadows (chociaz mysle, ze to niema znaczenia).

software 3sd Max9; 3dsMax8

 

Thanks in advance

p.s. sorry 4 my polish ;]

 

shadowmi8.jpg

Link to comment
Share on other sites

podlub przy opcji antyaliasing, wyglada na to ze dla obu passow granica zakresu to "nie jego dzialka"...

 

ale widze ze to co masz da sie przeskoczyc, wyrenderuj obiekt oddzielnie po wszystkim na alfie i doklej... w tym wypadku to biale g bierze sie wlasnie z antyaliasingu podloza...

 

edit:

aaaa.... Ty ludzkiego nie znasz dobrze....

 

the problem You have is caused by antialiasing failure, try to turn off antialiasing for this particular model, or render it once again after all with alpha and than paste it on this shadow... enother idea is to attach objects, but with such extremal light/shadow (You used extremly white color, which is not best idea for this purpouse, use color balance in photoshop later if You need something really white) the problem could not be solved so easy, try tu use enother color for background, from the middle range of color bar...

Link to comment
Share on other sites

vv3k70r dzieki za odp.

Otooz sproobowalem wyrenderowac objekt oddzielnie z alpha do .tga formatu, przy tym zaznaczjac "Pre-Multiplied Alpha", takze wyrenderowalem oddzielnie cienie za pomoca Matte/Shadow, einvoirment color nastawilem czerwony (dla testowania R:255 G:0 B:0). Przy Imporcie do After Effects kazdego z pass'oow, wybralem "Premultiplied Matted With Color R:255 G:0 B:0 (ten samy czrewony kolor). Powklejajac wszystko na swoje miejsca uzyskalem ten sam problem. Otooz to "biale g" nie jest powodem swiatlego podloza, poprostu podczas antialiazingu on zagladza kontury oddzielnych pass'oow, co powoduje ten odstep miedzy nimi. Proobowalem poszperac w opcjach antialiasingu, niestety nie znalazlem rozwiazania. Moze gdzies, cos opuscilem?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy