Jump to content

wlaczone swiatla -nastaje ciemnosc


zumberek
 Share

Recommended Posts

Witam.

Mam problem tak jak w tytule.Mysle ze to bedzie bzdura ale slecze nad tym juz dosyc dlugo. Kiedy mam swiatla mentalowe np. mr Area Omni w scenie, obiekt staje sie czarny ledwie widoczny, to samo jest przy innych swiatlach. Parametr multiplier w ustawieniach swiatla daje efekt tylko w view-porcie. W momencie kiedy wywalam swiatla - obiekt ma kolory -wyglada normalnie.Wlaczenie FG tez nic nie daje.Co jest z tym nie tak?

Link to comment
Share on other sites

Zasieg near i far siega w zasadzie juz poza obiekt, poza tym kiedy krece tymi parametrami i renderuje nadal przyciemnawy obrazek sie nie zmienia. Moge dowalic mR spot light na obiekt tez nic rendering nie drgnie , tyle ze sie zmienia w vieporcie.

Link to comment
Share on other sites

Może masz exponent ustawione na dużą wartośc, np. 2 (inverse square). W viewporcie światło chyba wygasza się wraz z odległością w postępie liniowym (jeśli w ogóle się wygasza). Jeśli masz exp ustawione np. na 2, okaże się, że w viewporcie obiekt jest mocno oświetlony, a na renderze światło w ogóle do niego nie dociera...

 

Spróbuj zwiększyc moc światła, powinno pomóc (jeśli to jest przyczyną).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy