Jump to content

problem z PaintSkinWeightsTool


ozonex
 Share

Recommended Posts

Witam

 

Ostatnio natrafiłem na dziwną rzecz podczas rigowania w Maya. Od dłuższego czasu pracuje już w tym programie ale nie spotkałem jeszcze na coś takiego. Chodzi o to że gdy nadam modelowi SmoothSkin lub Interactive skin bind na model narzędzie Paint Skin Weight Tool nie chce działać prawidłowo.

 

Nie mogę przez nie zaznaczyć kości (by pokazało na czarno biało wagi na modelu), a brush narzędzia jest przekreślony wielkim krzyżykiem. Dodatkowo ilekroć nie wybiore narzędzia wyskakuje error w polu komunikatów:

// Error: No object matches name: dowodca_root.liw

dowodca_root to główna kość szkieletu

 

Czy jest coś o czym nie wiem? Może szkielet jest gdzieś zablokowany albo brakuje mu czegoś.

 

th_skinProblem.png

Link to comment
Share on other sites

Prawdopodobnie importowałeś ten szkielet z FBXa. Spotkałem się z tym problemem ale nie miałem czasu go rozwiązać, zostawiłem po prostu skina taki jaki był.

 

Może ten skrypt coś pomoże > http://www.creativecrash.com/maya/downloads/scripts-plugins/character/c/convert-wrap-deformer-to-skincluster

 

Trzeba będzie zduplikować mesh, dać go na wrap deform i potem przekonwertować skryptem na skin. Tu jest jak się tego używa > http://www.puetz3d.com/WrapDemo.htm

 

Jak zadziała to daj znać.

 

 

 

_

Link to comment
Share on other sites

faktycznie, model i szkielet były importowane z FBX. Z tym skryptem miałem problemy, przy konwersji na wrap strasznie zamulało a potem i tak skrypt wywalał błąd że nie wykrył Wrapa

 

Rozwiązałem problem inaczej: wziałem JointToola, włączyłem snap'owanie do obiektów i stworzyłem szybko kilkoma klikami nowy szkielet o identycznej budowie :) i już po problemie. Tylko z nazwami kości trzeba się pobawić. U mnie akurat musiałem tak czy siak tworzyc cały rig od zera, ale w przypadku gdyby ktoś chciał zaimportować już istniejący by go poprawić to może mieć problem.

Edited by ozonex
Link to comment
Share on other sites

przetestowałem przed chwilą jak to jest na wcześniejszych wersjach i faktycznie, w wersji 2010 nie ma najmniejszego problemu ze skinowaniem.

Dodatkowo sprawdziłem, że gdy wyexportowałem model do innych formatów po imporcie już nie dawało się ich skinować. Wygląda to troche tak jakby maya z automatu włączała blokade na skin który został zaimportowany. Tylko co z tym dalej zrobić

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy