Jump to content

Skin/edit envelopes nie dziala poprawnie?


pepik
 Share

Recommended Posts

Witam!

 

 

8cfc31db23c53.jpg

 

 

 

Mam taki problem, zabieram się za rigowane postaci i animacje, jednak na samym poczatku napotkalem problem z poprawnym skinowaniem, do kosci przypisane jest wiecej obszaru niz powinno, kiedy wchodze w różne kości w edit envelopes podświetlaja mi sie na czerwono miejsca na obiekcie które nie powinny się zaznaczac, mało tego gdy próbuje w jakikolwiek sposób zmieniać wartości abs weight tych wierzcholkow nie dzieje sie nic, tzn dalej zostaja zaznaczone na czerwono a wartosc moge wpisywac jakakolwiek (w tym wartosc 0!!). Dodam tez ze znajomy ma taki sam problem wiec nie wiem czym to moze byc spowodowane, obaj nogi pajaka dolaczalismy atachem do korpusu. wszystko znajduje sie na jednej siatce.

 

I drugie pytanie, czy mozna kopiowac kosci z jednej odnogi do innej? czy kazda odnoga zbudowana ma byc z kosci od poczatku? Czy lepiej przypisac kosci do osobno stworzonej odnogi przekopiowac a pozniej dodac do korpusu??

Edited by pepik
Link to comment
Share on other sites

1. czerwone bo są przypisane do tej kości z automatu. envelop odwłoku ich nie łapie. gdy zwiększysz zakres envelopa odwłoku to pomoże. możesz także przypisać wagi tych vertexów do kości odwłoka. vertex MUSI posiadać wagę dla minimum jednej kości. jak żaden envelop nie łapie ich zakresem, wtedy skin defaultowo przypisuje im 100% dla znajdującej się w pobliżu kości.

 

2a. tak

2b. tak też można

2c. jeśli zaoszczędzi tobie to czasu i nie ucierpi na tym animacja to warto.

 

liczy się efekt, a nie sposób wykonania.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy