Jump to content

AE: Motion Tracking problem


Guest kakaku
 Share

Recommended Posts

Guest kakaku

Witam. Uczę się właśnie obsługi AE. Chciałbym użyć Motion Tracker'a aby potem dodać coś z 3ds maxa. I tutaj pojawia się problem ponieważ gdy ustawiam te dwa kwadraty i naciskamikone PLAY to mi pixeli nie śledzi na tyle dobrze abym mógł potem tegu użyć-poprostu ssię gubi.... nie wiem w czym rzecz ponieważ robie bardzo podobnie jak w tutorialach a i tak nic z tego:(

Czy mógłby mi ktoś pomoc? Miał ktoś taki problem? Czy są jakieś zasady ustawienia tych kwadratów? Wiem tyle że muszą być na dobrze widocznym miejscu i aby były ustawione na wyrażnej rzeczy która odbiega od reszty danego fragmentu.

Z góry dzieki za rady :)

Link to comment
Share on other sites

Poreguluj sobie wielkość tych kwadracików - kwadracik wewnętrzy to jest fragment obrazu którego tracker będzie szukał. A ten większy to obszar który zostanie przeszukany w kolejnej klatce. Czyli jak zwiększysz ten drugi to trackowanie będzie szło wolniej ale mniejsza szansa, że się zgubi. No i nie wiedzieć czemu jak się trackuje klatka po klatce a nie za pomocą tego przycisku play to jest dokładniej.... I jak czasem Ci się zgubi to go ręcznie popraw ;) Jak dalej będziesz miał problemy to może niewyraźny punkt do trackowania wybrałeś?

Link to comment
Share on other sites

Guest kakaku

ok, dzieki troche pomoglo, ale i tak musze poprawiac co klatke;) a moglbys mi powiedziec jeszcze jaka jest roznica miedzy jednym trackerem (transform) a dwoma (+rotate)?

Link to comment
Share on other sites

Transform śledzi tylko położenie, a rotate również obrót, czyli gdy np komuś trzęsła się ręka, to wystarczy transform, ale gdy np lekko obracał kamerą wokół osi X - prostopadłej fo filmowanego obiektu, to pomoże rotate. Zależy co chcesz ustabilizować, drugi tracker jest potrzebny, żeby porównywał kąt między dwoma trackerami, dzięki czemu może ustabilizować obrót. Analogicznie Scale.

Link to comment
Share on other sites

Guest kakaku

ok tracking działa. nienajlepiej ale chociaz o niebo leppiej niz wczesniej.

teraz mam problem z kamera... uzywam skryptu ae3d i gdy wrzucam kamere do maxa to tylko ruch jest w ostatniej klatce.... ale zauwazylem ze w polozeniu w ae tej object null mam tylko 2 parametryu jakby tylko x i y... a w tutorialu byly 3. nie wiem czy to tego wina....

Link to comment
Share on other sites

Nie masz włączonego switcha warstwy 3d. Moim zdaniem zanim się zacznie kombinować z bardziej zaawansowanymi technikami typu 3d parentowanie do nulla :D to trzeba zrobić kurs typu "basics" albo "essentials". Przydaje się również wydrukować skróty klawiaturowe i przykleić nad biurkiem. Jeśli nie chce Ci się czytać książek lub helpa to polecam kursy lyndy. Pozdrawiam

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy