Jump to content
  • 0

3ds Max 2009 - Problem z Viewportami


kuro

Question

Pacjent: 3DS Max 2009 x64, Windows 7 Ultimate x64, Nvidia GeForce 560 GTX, AMD Phenom II X4

Problem: złe odświeżanie viewportów

Objawy: przy edytowaniu poly, poruszaniu lub opcji fillet / chamfer vertexów bądź edgeów obszar edytowanego miejsca "znika" na czas edycji, dopóki nie puszczę klawisza myszki lub nie kliknę w innym miejscu viewportu. Czasami podczas edycji obiektu (spline / poly - nie ma różnicy), obiekt z viewportu innego niż perspective znika całkowicie (w trybie wireframe), aż nie wyjdę z edycji obiektu lub nie zaznaczę paru elementów - wtedy te elementy się pojawiają.

Podejrzenia: prawdopodobnie coś ze sterownikami do karty graficznej (aktualizowane wczoraj ze strony Nvidii), bądź też ustawieniem viewportu... Problem nie występował wcześniej, przez wiele lat pracy z programem. Pojawił się wczoraj, bez żadnych specjalnych modyfikacji komputera czy software'u.

 

Dodatkowe:

Driver configuration (in Max):

Geometry

x - display all triangle edges

v - use cached D3DXMeshes

v - use wireframe faces

v - use triangle strips

v - for wirefrime objects

 

Window Updates

x - redraw scene on window expose

x - redraw in maximized viewport

x - redraw in unmaximized viewport

v - use incremental scene updates

 

Appperance Preferences

x - enable antialiased lines in wireframe views

background texture size = 512

v - match bitmap size as closely as possible

download texture size = 512

v - match bitmap size as closely as possible

 

texel lookup = linear

mipmap lookop = none

 

Będę bardzo wdzięczny za jakąkolwiek pomoc, z góry dziękuję! :)

Pozdrawiam.

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Spróbuj service packa do maxa. Może to poprawi sytuacje.

Edit: Nie doczytałem że problem pojawił się nagle. Walcz, praca z maxem buduje charakter.

Ustawienia raczej nie mają tu znaczenia. A sprawdź jak się zachowuje przy wyborze innego drivera, np software.

Edited by PICsell
Link to post
Share on other sites
  • 0

PICsell, dzięki za dobrą wiarę i wsparcie. ;) Niestety, samo to nie pomoże, a SP do Maxa mam od początku instalki, wszystkie hotfixy itd. Poeksperymentowałem, i okazuje się, że pomogło zaznaczenie "redraw in maximized viewport". Poprawiło się, teraz walczę z podobnym wątkiem, ale odnośnie tekstur, które brzydko i bardzo niedokładnie wyglądają na modelach... chyba, że zaznaczy się poszczególne polygony i zmieni ID, wtedy na chwilę cały model wygląda dobrze, ale gdy kliknę gdziekolwiek indziej, znowu mam sieczkę... :P Ah, faktycznie, Max buduje charakter (oraz parę chorób psychicznych, ale to szczegół).

 

Pozdrawiam!

Link to post
Share on other sites
  • 0

No i widzę już babola. Use cached D3DXMeshes - gdy zaznaczone, tekstury na modelu wyglądają bardzo niedokładnie i brzydko. Gdy odznaczone, cieszmy się prędkością viewportu około 2FPS. CUDNie.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy