Jump to content

error :(


nielot007
 Share

Recommended Posts

Witam!!

mam taki problem :(

wywala mi maxa podczas renderingu,pojawia sie taki obrazek(w zalaczniku) moj objekt ma ogromna "wage" ma okolo)moze 3mln nie wiem dokladnie bo mi sie wywala,ale niech swiadczy o tym plik maxa ktory wazy prawie 60mb) 4mln(!!!) tri da sie to jakos wyrenderowac??

 

napewno to wina wielkosci objektu ale taka musi byc :) bo nie chce mi sie modelowac objektow jeszcze raz aby mniej wazyly :(

 

help bo przeciez nie zmarnuje tygodnia ciezkiej pracy :(

pozdro

Link to comment
Share on other sites

Regulacja "Memory Limit",włączenie "Use Placeholder Objects", "Conserve

Memory" i "Use mental ray Map Manager", ustawianie "Large BSP" (w przypadku

złożonej/licznej geometrii w scenie)

wiec tak. zrobilem tak jak wyzej ale mi maxa wywala bez bledow (ktore podalem wyzej) tylko pojawia sie raport :(

xeav dalem 3072 gdyz tyle bylo standardowo :(

Link to comment
Share on other sites

Witam!!

w scaline nie chce renderowac jak daje swiatla :(

a jesli chodzi o scene to nie ma zandej sceny jest tylko jeden model(ktory ma duuuzo mniejszych obiektow) ktory wazy ok (cos w granicach moze mniej) 3mln-4mln tri :) nie ma wlasnie nic zadnej kaustyki zadnych swiatel gi nic :(

edit

polycout--> 3.627.559 faces :)

Link to comment
Share on other sites

Bardzo dziwne :) Mental powinien sobie poradzić (ja mam 1GB Ram i SWAMP 2GB i bez problemu obliczył 9mln tris)

Wygląda na to że chyba ten pliczek masz jakiś skopany (czy podczas modelingu max Ci się wywalał??)

Zawsze możesz spróbować lekko przebudować scenę (np. wiele takich samych modeli zastąpić instance a nie copy)

Czy próbowałeś eksportować ten obiekt do innego programu i tam renderować??

Link to comment
Share on other sites

Bardzo dziwne :) Mental powinien sobie poradzić (ja mam 1GB Ram i SWAMP 2GB i bez problemu obliczył 9mln tris)

Wygląda na to że chyba ten pliczek masz jakiś skopany (czy podczas modelingu max Ci się wywalał??)

Zawsze możesz spróbować lekko przebudować scenę (np. wiele takich samych modeli zastąpić instance a nie copy)

Czy próbowałeś eksportować ten obiekt do innego programu i tam renderować??

tez mam 1gb ramu :(

sprobuje z tym instance (bo zawsze dawalem copy i attache je w edit. poly)

podczas modelingu max mi sie nie wywalal wszystko ladnie dzialalo

nie probowalem exportowac, bo nie mam innego :(

w sumie mam tak ze jak daje turbosmooth na pewien obiekt i zwiekszam iteration na jeden a pozniej na dwa to mi max wywala :(

gdyz ja robie zawwsze ze wlaczam smootha na render (zeby pokazywal rezultat podczas renderingu aby mi sie viewporty nie ciachaly) aha i daje tez render hidden geometry gdyz te najciezsze obiekty sa ukryte :)

aha moze mam cos skopanego w pliku bo wazy ponad 60mb (moze nawet 62) :)

pozdro :)

Link to comment
Share on other sites

salvage--> nie to napewno nie wina ramu :)

ok przeprowadzilem maly "test"

wlaozylem do nowej sceny(nowy plik) najwiekszy objekt (ktory waze ponad 2mln tri po nadaniu turbosmooth'a iteration 1) i scaline renderuje a mental juz nie , scaline wywala (jak mam caly obiekt) jak dodam pare swiatel typu omni(1) i target direct(1) :(

badziewnie tyle robielm model i nawet nie mozna go wyrenderowac :(

moze mental ma jakies ograniczenia wzgledem jednego obiektu tzw ze jeden obiekt nie moze miec okreslonej wagi(tri) ??

Link to comment
Share on other sites

a może mogłbyś to zrenderować na "raty" żeby nie zmarnować swojej pracy. Wiesz... tego kolosa na raz , a potem te mniejsze rzeczy na dwa i skomponować jakoś , gdzieś.

Możesz zdradzić co tak bardzo waży ? Może Space shuttle dla NASA i jestes objęty tajemnicą CIA przez NBA :P

Link to comment
Share on other sites

mintrill--> :)

Jim-->tez myslalem zeby na raty ale to nie to samo :D a poza tym to mi mental jednej czesci nie chce wyrenderowac bo chyba za duzo wazy:( :(

moj project nie jest tajemnica moge zdradzic jest to czalg :)

pozdrawiam

Link to comment
Share on other sites

Wiesz, miałem taki sam problem, tylko, że przy atachowaniu obiektów i to przy dużo mniejszej ilości ścianek. Okazało się, że to wcale nie wina ramu, pliku stronnicowania czy systemu, co po prostu błąd Maxa - skonwertowałem moje obiekciki do Editable Poly i problem się rozwiązał.

 

U Ciebie co prawda ewidentnie wygląda to na brak pamięci, ale chyba sprzęt jakoś mimo wszystko powinien dać radę (ja kiedyś mialem ponad 1,5mln na duuużo gorszym sprzęcie i dalo się wyrenderować). Tak więc skoro nic nie działa, to może w ostateczności spróbuj właśnie przekonwertować - sam się już przekonalem, że komunikaty Maxa bywają mylące...

Link to comment
Share on other sites

shogun--> hehe:) siatki nie pokaze ;) a "optymizowyc" nie bede gdyz napewno by mi to zrypalo obiekt ;)

Jim--> hehe nie :D zwykle renderki bez mat.szary obiekt ;)

Lucas-->sporoboje przekonwetowac :), ale moge tez zrobic taki test czy to wina sprzetu czy pliku max'a zrobie jakis obiekt (belejaki) z duuuza iloscia trojkatow (np.1mln)i prztestuje komp'a i max'a jak wywali to wina kompa jak nie to wina maxa :)

pozdro

Link to comment
Share on other sites

Witam!!

ok troche pokombinowalem

zrobilem obiekt (moją swieczke) ktory wazyl okolo 500k tri dalem na niego ms'a z iteration 2 (jako render) i pojawilo sie to co w zalaczniku wiec sobiwe pomyslaem zeby podzielic go na 4 czyli waga tyle samo ale obiekty copy (niepolaczone) i co?? wyrenderowal :) hehe teraz sprawdze to na moim czalgu, ale i tak watpie zeby wyrenderowal :(

pozdro

Link to comment
Share on other sites

Instance robisz dla wielu takich samych obiektów w scenie

(wszystkie pochodzą z jednego źródła i oszczędzasz pamięć) i jak je dodasz do jednego edit. poly to i tak masz to samo.

Co do ograniczeń dla jednego modelu to dziwne ale 3.1 mln renderuje (def. ustawienia, 1mr omini, w 5min) ale przy 6mln też się mi max wywalił :)

Przy podziale obiektu to najlepiej renderować do pass'ów.

Ponoć XSI5 ma lepiej rozwiązany problem mentala z pamięciom ale nie testowałem.

Link to comment
Share on other sites

andy_a--> !! z tym instace dziala !! tzw jeszcze nie renderuje hehe ale powinno musze podawac jeszcze pare obiektow jako instace

ale mam pytanie jak dobrze pamietam to inscae(obiekty) nie mozna laczyc poprzez attache tak??

Link to comment
Share on other sites

no nie wiem bo mi łączy :)

dokładniej to możesz przyłączyć do obiektu macierzystego i do każdego innego "nieinstance" ale od kopi (instance) nie możesz przyłączyć kolejnych kopii (instance) tego samego obiektu (inne obiekty można).

Mam nadzieję, że ktoś coś z tego zrozumiał :P

  • Like 1
Link to comment
Share on other sites

no wlasnie to troche bezsensu :)(nie to co piszesz)

jak dobrze rozumiem np. robie instace obiektu pozniej kolejna czyli mam maciezysty obiekt i dwie "kopie" insctace i moge te dwie kopie przypisac do maciezystego?? bo wiem ze instace do instace nie przypisze??

Link to comment
Share on other sites

dokładnie, ale lepiej napisz jak tam mental??

 

P.S

Jeżeli chodzi o Mental Ray'a to polecam się przesiąść na XSI (niedosyć, że mental jest podstawowym renderem to jeszcze świetnie rozwiązali rendering na pass'ach)

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy