Jump to content
GrafMax

Dziury w normal mapach

Recommended Posts

Cześć,

 

Dopiero zaczynam z zBrushem (v 3.1) i mam problem, rozwiązania którego nie znalazłem.

 

Kiedy wypalam mapy, brakuje w nich face'ów. Dzieje się tak zarówno gdy używam ZMapper jak i Displacement Exporter'a. Próbowałem róznych ustawień i nic.

Dodam, że UWV z maxie zrobione jest prawidłowo, bez overlapów.

Co robię źle?

Share this post


Link to post
Share on other sites

Siatka ma sporo odwróconych face'ów, w zbrushu tego nie widać ale jak otworzysz model w maxie to jest nieciekawie:

beztytuuwu3.jpg

To nie jest chyba model bazowy jaki wrzuciłeś do zbrusha chyba że wrzuciłeś go z meshsmooth. Problemy mogą wynikać ze złego mapowania(np odwrócone poly na uv'ce) albo z topologii siatki(dużo trójkątów) a może z czegoś innego różnie to bywa.

Jak chcesz zachować sculpt i wypalić dla niego normalki to musisz zrobić retopologię na podstawie zewnętrznego modelu albo podmienić uv'ki dla tego. Podmiana morph targeta raczej zakończy się fiaskiem bo musisz poprawić model przez co na pewno zmienisz numerację vertexów. Ja bym spróbował zaimportować model do maxa, usunąć jedną połowę i poprawić pozostałą(poprawić dlatego że przez te odwrócone face'y niektóre polygony zostały przecięte krawędzią przez co zrobiły się z nich dwa trójkąty) po czym dodać symetrię i zmapować(trochę gęsta siatka ale bardzo prosta do zmapowania) na nowo. Możesz też użyć modelu który masz zapisany w maxie i na nim sprawdzić czy nie ma błędów i ewentualnie poprawić je i użyć do zamiany mapowania. Jak już będziesz miał zmapowany model to otwórz tamten wyexportowany z zbrusha co wrzuciłeś linka do niego i zamień mu mapowanie np w darmowym uvmapperze na to które ma poprawiony model, musisz koniecznie użyć modelu z zbrusha bo ten z maxa nie nadaje się na morph targeta.

Jak już będziesz miał poprawione mapowanie to w zbrushu przechodzisz na pierwszy poziom podziału, następnie w tool morph target klikasz store mt i importujesz obj z poprawionym mapowaniem.

 

PS: jak nic nie pomoże to wrzuć model bazowy ale nie z zbrusha tylko zapisany w innym programie(3ds max?) przed edycją w zbrushu.

Share this post


Link to post
Share on other sites

Tomala, masz rację model jest z meshsmooth'em. Czy to jest przyczyną odwróconych face'ów? Co zrobić, aby poly na UV'ce nie były odwrócone i jak sprawdzić czy są?

Ten model generalnie jest do testów w zBrushu, więc nie upieram się przy nim. Chce się po prostu tego nauczyć. Przejrzałem już masę tutoriali i niestety, cały czas mam ten sam problem.

 

zBrush potrzebny mi jest do pracy dyplomowej - chcę zesculptować postaci do animacji. Byłbym Ci wdzięczny za kilka podpowiedzi i wskazówek;)

 

 

 

pozdrawiam

Share this post


Link to post
Share on other sites
zBrush potrzebny mi jest do pracy dyplomowej - chcę zesculptować postaci do animacji. Jeśli się tego nie nauczę w najbliższym czasie, to praca bedzie musiał zmienić swój kształt, a tego bym nie chciał. Byłbym Ci wdzięczny za kilka podpowiedzi i wskazówek;)

 

 

 

pozdrawiam

 

Moja rada?

Jak zrobisz fajne klimatyczne sceny statyczne to ominie Cię wiele frustracji.

Masz tyły w mapowaniu i chcesz robić modele, textury, materiały, skinning, rig, animki, kamery, oświetlenie, rendery, postproces, montaż...

Trzeba mieć tak obcykany workflow że ojejkujejku.

 

Też chciałem zrobić animkę, na scenach statycznych się skończyło, pozatym już je robię od roku i ciągle w lesie jestem.

Moja praca zmieni więc zapewne kształt po raz trzeci a też tego nie chciałem.

Duży projekt na pracę dyplomową to samobójstwo.

 

W sumie nie wiem jaki masz zamysł, więc sorki jakby co, życzę Ci jak najlepiej, ciężką pracą można naprawdę wiele osiągnąć.

Tak tylko z autopsji wnioskuję...

 

pozdrawiam!

Share this post


Link to post
Share on other sites
(...)

W sumie nie wiem jaki masz zamysł, więc sorki jakby co, życzę Ci jak najlepiej, ciężką pracą można naprawdę wiele osiągnąć.

(...)

pozdrawiam!

 

Ostatni wniosek słuszny, też tak myślę i tego się trzymam.

Nie interesują mnie statyczne sceny. Nie interesuje mnie też, zajmowanie się czymś co już umiem. Mam tyły w mapowaniu i świetną okazję, aby to nadrobić.

Przystępując do każdego projektu, planuję go tak, aby było w nim co najmniej kilka problemów, których rozwiązać nie potrafię na samym początku. Jak na razie, metoda świetnie się sprawdza - gwarantuje ciągły postęp i rozwój. Podstawowa zasada: nie odpuszczać. Gdybym w to nie wierzył, nie przesuwałbym obrony, tylko zrobiłbym coś na miarę umiejętności, które mam teraz, a nie które będę miał po skończeniu projektu;) rozumiesz....

 

Jeśli więc wiesz coś na temat wątku i chciałbyś się podzielić wiedzą, będę wdzięczny.

Czas leci, trzeba ruszać do przodu ;)

Share this post


Link to post
Share on other sites

Ten model jest tylko źle zmapowany ,popraw mapowanie te dziury są tylko tym spowodowane.

Share this post


Link to post
Share on other sites
Ostatni wniosek słuszny, też tak myślę i tego się trzymam.

Nie interesują mnie statyczne sceny. Nie interesuje mnie też, zajmowanie się czymś co już umiem. Mam tyły w mapowaniu i świetną okazję, aby to nadrobić.

Przystępując do każdego projektu, planuję go tak, aby było w nim co najmniej kilka problemów, których rozwiązać nie potrafię na samym początku. Jak na razie, metoda świetnie się sprawdza - gwarantuje ciągły postęp i rozwój. Podstawowa zasada: nie odpuszczać. Gdybym w to nie wierzył, nie przesuwałbym obrony, tylko zrobiłbym coś na miarę umiejętności, które mam teraz, a nie które będę miał po skończeniu projektu;) rozumiesz....

 

Jeśli więc wiesz coś na temat wątku i chciałbyś się podzielić wiedzą, będę wdzięczny.

Czas leci, trzeba ruszać do przodu ;)

 

Ok, spoko:) Widzę, że wiesz na co się porywasz. Powodzenia zatem:D

A propos problemu chłopaki już wszystko powiedzieli chyba.

 

pozdrawiam!

Share this post


Link to post
Share on other sites

Plik modelu obj. z nową uv i jest tam też plik eps. z siatką przydatny przy texturowaniu w photoshopie po otwarciu tego pliku w shopie określasz wielkość textury w pixelach i musisz zmienić go na Rgb, bo otwiera się jako CMYK.

 

link do modelu

------------------------------------

http://rapidshare.com/files/112927966/TORS_uv.rar.html

Share this post


Link to post
Share on other sites

GrafMax jak chcesz robić animację to popracuj nad topologią siatki a szczególnie miejscach zgięć kończyn. Zbrusha bym użył do kształtowania modelu(jak już będzie dobra topologia) i dodawania detalu który później na normalce wypalisz no chyba że masz na czym renderować to wtedy również displacement. Nie porywaj się też na bardzo skomplikowane modele bo jak przyjdzie Ci to riggować i skinnować to polegniesz choćbyś nie wiem jak się starał.

Mówisz że uczysz się mapować więc po problemach z tym modelem powinieneś zwrócić uwagę na to czy poly na uv'ce nie są odwrócone. Najlepiej przy mapowaniu nie używaj maxowego checkera tylko nałóż na model jakąś szachownice ze znakami kontrolnymi żebyś wiedział czy polygony nie są odwrócone. Btw jak masz taki model organiczny jak ten to używaj pelta on nigdy nie odwróci polygonów a wystarczy poprowadzić odpowiednio szwy zapodać pelt i zrelaxować i w chwilę masz modelik zmapowany tak jak to zrobił Zeet.

Jak zrobisz mało szwów na siatce to przy relaxie ustaw sobie wartość stretch na więcej niż zero co sprawi że nie będziesz miał nachodzących na siebie polygonów po relaxie. Wiesz, albo więcej szwów i równo rozłożona siatka albo mniej ale wtedy będziesz miał mniejsze lub większe jej rozciągnięcia. Pozdro.

Share this post


Link to post
Share on other sites

Tomala, po to potrzebny jest mi zBrush, aby robić właśnie displacement detali na obiektach low-poly, które będę animował. Bez przesady panowie, wiem jak się robi animacje. Natomiast jestem "zielony" z zBrusha i właśnie pojawił się następny problem:/

Dziwna sprawa Displacement Exporter nie zapisuje map na dysku. A przynajmniej system ich nie widzi, bo jak próbuję ponownie wyeksportować mapę do tej samej lokacji, to zBrush komunikuje mi, że taka mapa już tam istnieje i pyta czy ma ją nadpisać.

(nie, nie jest to kwestia ukrytych plików w eksploratorze;))

 

Czym to jest spowodowane?

 

EDIT:

 

Okazuje się, że zBrush nie chce zapisać mapy w wybranej lokacji, ale zapisuje bespośrednio na dysku w tym przypadku D:

Da się to zmienić gdzieś w preferencjach? nie znalazłem:/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We are using cookies. Read about our Privacy Policy